User Tools

Site Tools


acer_aspire_4520

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

acer_aspire_4520 [2017/09/09 22:48] (current)
don created
Line 1: Line 1:
 +<vote Acer-Aspire-4520-Rating check=ip>​
 +How do you rate this laptop with Linux?
 +* Excellent
 +* Good
 +* Fair
 +* Poor
 +* Unusable
 +</​vote>​
 +====== Acer Aspire 4520 ======
 +===== Introduction =====
 +This is a guide to running Linux with the Acer Aspire 4520 laptop. Thanks to Tiago for these details.
 +
 +This guide is intended to provide you details on how well this laptop works with Linux and which modules you need to configure. For details on how to actually install and configure the required modules have a look at [[Installation Guide|our guides]] section for distribution specific instructions.
 +===== Editing This Page =====
 +If you would like to edit this page please first view our [[Editing Guidelines]].
 +===== Specifications =====
 +| Name|Acer Aspire 4520|
 +| Processor|AMD Turion 64 X2 TL-52 1.6GHz|
 +| Screen|14.1"​ WXGA Widescreen|
 +| RAM|1GB|
 +| HDD|120GB|
 +| Optical Drive|DVD+-RW|
 +| Graphics|NVIDIA Geforce 7000M|
 +| Network|Nvidia Ethernet, Atheros AR5007EG 802.11bg|
 +===== Linux Compatibility =====
 +^Device^Compatibility^Comments^
 +| Processor|Yes| |
 +| Screen|Yes| |
 +| HDD|Yes| |
 +| Optical Drive|Yes| |
 +| Graphics|Yes| |
 +| Sound|Yes| |
 +| Ethernet|Yes| |
 +| Wireless|Yes| |
 +| Bluetooth|Not Tested| |
 +| 56K Modem|Not Tested| |
 +| USB|Yes| |
 +| Firewire|Yes| |
 +| Card Reader|Yes| |
 +| ExpressCard Slot|Not Tested| |
 +| Camera|Yes| |
 +===== Notes =====
 +The NVIDIA driver is supported by both the open source '​nv'​ module and the proprietary '​nvidia'​ module. For 3D support you will need to use the proprietary module. See our [[Installation Guide|guides]] for more details.
 +
 +You will need to install ALSA version 1.0.16 or later for sound support. Currently no Linux distribution includes this so you will have to manually install it. Again our [[Installation Guide|guides]] has details about doing this.
 +
 +For proper hardware support you will need to use kernel version 2.6.20 or greater.
 +
 +Tiago has further information at [[http://​acer-linux.blogspot.com/​]].
 +===== Summary =====
 +The main problem with this laptop is with the need to install the ALSA modules. However this shouldn'​t pose a problem for most users which makes this laptop a good Linux candidate. The ALSA issues will be release in future Linux releases.
  
acer_aspire_4520.txt ยท Last modified: 2017/09/09 22:48 by don